LEAP Australia and New Zealand

Service Disruption

Incident Report for LEAP Australia And New Zealand

Resolved

This issue has now been resolved.
Posted Aug 27, 2025 - 14:27 AEST

Identified

A small number of users may be experiencing issues with accounting services in LEAP.

We have identified an issue impacting this small subset of clients and are working towards a resolution.
Posted Aug 27, 2025 - 12:41 AEST
This incident affected: LEAP Accounting Services.