LEAP Australia and New Zealand

Third Party Outage affecting LEAP

Incident Report for LEAP Australia And New Zealand

Resolved

Third Party issue is resolved. We will continue to monitor.
Posted Oct 20, 2025 - 22:48 AEDT

Identified

LEAP users may experience issues signing into or using LEAP as normal. We have identified an issue affecting a Third Party provider which impacts us directly. We are monitoring and will provide an update as soon as possible.
Posted Oct 20, 2025 - 19:21 AEDT
This incident affected: LEAP Matter & Document Services, LEAP Accounting Services, LEAP Mobile, LEAP API Gateway, and LEAP 365.